2017-01-08 snapshot

Post anything about MX Simulator here. Please. I'm begging you.
jlv
Site Admin
Posts: 12355
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

2017-01-08 snapshot

Postby jlv » Mon Jan 09, 2017 3:26 am

Changes:
  • Fixed degenerate triangle test deleting tiny triangles.
  • POV export now exports all passes for models with more than one material.

Windows users: http://mxsimulator.com/snapshots/mx-2017-01-08-1331.exe
Linux users: http://mxsimulator.com/snapshots/mxbin-2017-01-08-1331

Replace mx.exe or mxbin with one of the above files. The default location for mx.exe should be "C:\Program Files (x86)\MX Simulator". I'd keep a backup of the originals since these aren't well tested.

You'll also need to extract this in your install folder:
http://mxsimulator.com/snapshots/zzzrtestzx.zip
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

User avatar
AidenS
Posts: 83
Joined: Sat Jul 11, 2015 10:21 pm
Team: LogoDaddy Racing

Re: 2017-01-08 snapshot

Postby AidenS » Mon Jan 09, 2017 3:32 am

So many in so little time

User avatar
AidenS
Posts: 83
Joined: Sat Jul 11, 2015 10:21 pm
Team: LogoDaddy Racing

Re: 2017-01-08 snapshot

Postby AidenS » Mon Jan 09, 2017 3:36 am

POV export now exports all passes for models with more than one material.

What this mean

User avatar
AHeckman2
Posts: 2177
Joined: Thu Aug 06, 2015 12:11 am
Team: Vital MX Racing
Location: Michigan, USA
Contact:

Re: 2017-01-08 snapshot

Postby AHeckman2 » Mon Jan 09, 2017 4:25 am

Jlv fixing bugs constantly it seems like. Thanks for your continued work on this! Love it
Image

User avatar
DCreedz#523
Posts: 891
Joined: Fri Mar 29, 2013 11:11 am
Team: Greef Clothing
Location: Australia
Contact:

Re: 2017-01-08 snapshot

Postby DCreedz#523 » Mon Jan 09, 2017 8:29 am

jlv wrote:Changes:
  • Fixed degenerate triangle test deleting tiny triangles.


Thank you!!!! Was wondering what was up with that. For a while, any server I tried to join from an online browser would give me that degenerate triangles message and then the whole game would crash. I've been checking the Servers section, then typing the server name into the game, hopefully this fixes it! Thanks JLV =)
Image

James Webb
Posts: 779
Joined: Wed Jan 02, 2013 1:26 am
Team: Evergood
Location: California

Re: 2017-01-08 snapshot

Postby James Webb » Mon Jan 09, 2017 9:02 am

Thank you for the fix JLV, everything seems fine on my end now! :D
Image

Chris17TMR
Posts: 10
Joined: Mon Jan 09, 2017 8:23 am
Team: Honda South Italy
Location: Italia
Contact:

Re: 2017-01-08 snapshot

Postby Chris17TMR » Mon Jan 09, 2017 11:43 am

JLV thanks to continuous fix bugs, but I wonder why do not you arrange a new pipe sound for everyone?

User avatar
onefoureight
Posts: 904
Joined: Sun Dec 23, 2012 2:54 am
Team: Not Splitfire
Location: Shit Posting Capital of the world

Re: 2017-01-08 snapshot

Postby onefoureight » Mon Jan 09, 2017 3:34 pm

No we just need a rider shadow.
2015 Australian Supercross 450 champion | rF Villain | Wolf Pack Racing Leader | CBL Gaming

barrington314
Posts: 6060
Joined: Fri Feb 18, 2011 6:03 pm
Team: me
Location: Charleston, SC

Re: 2017-01-08 snapshot

Postby barrington314 » Mon Jan 09, 2017 11:14 pm

"POV export now exports all passes for models with more than one material."


True to your word. Thank you sir. I will be "testing" that tomorrow for San Diego SX shadows. :wink:

User avatar
RideRed04
Posts: 25
Joined: Wed Jun 03, 2015 1:09 am
Team: Privateer
Location: tonopah, az

Re: 2017-01-08 snapshot

Postby RideRed04 » Tue Jan 10, 2017 2:56 am

just downloaded this update and all the 17 bikes are weird looking like the bike skins isn't the right one.
Image

Zmen36
Crushed Dissenter
Posts: 115
Joined: Wed Mar 23, 2016 4:17 pm
Team: Privateer

Re: 2017-01-08 snapshot

Postby Zmen36 » Tue Jan 10, 2017 8:02 pm

jlv wrote:Changes:
  • Fixed degenerate triangle test deleting tiny triangles.
  • POV export now exports all passes for models with more than one material.

Windows users: http://mxsimulator.com/snapshots/mx-2017-01-08-1331.exe
Linux users: http://mxsimulator.com/snapshots/mxbin-2017-01-08-1331

Replace mx.exe or mxbin with one of the above files. The default location for mx.exe should be "C:\Program Files (x86)\MX Simulator". I'd keep a backup of the originals since these aren't well tested.

You'll also need to extract this in your install folder:
http://mxsimulator.com/snapshots/zzzrtestzx.zip


Thanks for the update JLV!! :D

Anchor_b
Posts: 246
Joined: Fri Apr 03, 2015 11:27 pm
Team: Splitfire

Re: 2017-01-08 snapshot

Postby Anchor_b » Thu Jan 12, 2017 6:50 pm

I'm having a problem when i try to open the game with this snapshot. "Can't find game data" immediately pops up when I try to open it, I've tried to reinstall multiple times with no luck. Any idea JLV/anyone? Would it help reinstalling the game then download the snapshot? Yes i've done it the correct way as I always have and I have downloaded the zzzrtestzx file. Thanks in advance.

User avatar
Jack175
Posts: 407
Joined: Wed Dec 24, 2014 2:25 am
Team: YouTube Racing
Location: Toronto

Re: 2017-01-08 snapshot

Postby Jack175 » Sat Jan 14, 2017 4:41 am

The game keeps stuttering since I got this snapshot. Not sure if its just me or if others are having this problem?
jlv wrote:
Rush wrote:Why was UID 12235 not banned as well? he was doing the same thing.

Because he didn't come in here and confess like an idiot.

gduck
Posts: 2
Joined: Sat Jan 14, 2017 8:36 pm
Team: Privateer

Re: 2017-01-08 snapshot

Postby gduck » Sat Jan 14, 2017 9:12 pm

Anchor_b wrote:I'm having a problem when i try to open the game with this snapshot. "Can't find game data" immediately pops up when I try to open it, I've tried to reinstall multiple times with no luck. Any idea JLV/anyone? Would it help reinstalling the game then download the snapshot? Yes i've done it the correct way as I always have and I have downloaded the zzzrtestzx file. Thanks in advance.


Did you put the new mx.exe file in your install folder? I have had that error if the mx.exe file is not in the programs(x86)/mxsimulator folder.


I am having an issue where the game loads, but any item you click on the menu closes the window and does not work. Its not crashing, its basically just minimizing the mx simulator window.

jlv
Site Admin
Posts: 12355
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: 2017-01-08 snapshot

Postby jlv » Sun Jan 15, 2017 2:47 am

gduck wrote:I am having an issue where the game loads, but any item you click on the menu closes the window and does not work. Its not crashing, its basically just minimizing the mx simulator window.

Does it recognize keyboard input? Try switching to windowed mode.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.


Return to “General Discussion”

Who is online

Users browsing this forum: Shukar and 9 guests