Can't launch the game.

Post your questions here
deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Can't launch the game.

Postby deepestman » Sat Aug 18, 2018 1:46 pm

I wanted to try out the demo for the game to see if i really want to buy it or not, but whenever i launch it it chrashes. I've tried to change compatibility mode, run as administrator, update my graphics drivers. I really want to be able to play the game since it seems like one of the better bike simulators out there. I'm using windows 7, intel hd 3000 graphics, 4 gb of ram. I've tried everything i know of, but i'd like some help from you guys aswell.

jlv
Site Admin
Posts: 12912
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Can't launch the game.

Postby jlv » Sun Aug 19, 2018 12:41 am

Try installing the graphics driver from Intel's site.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Sun Aug 19, 2018 9:24 am

I recently just installed the lates drivers from intel's website. It did not fix my issue, unfortunately.

jlv
Site Admin
Posts: 12912
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Can't launch the game.

Postby jlv » Mon Aug 20, 2018 1:46 am

Open a file explorer window, type %localappdata% in the location bar and press enter, then open "MX Simulator Demo". There should be a file named "lastlog.txt" there. If you post that file it might show what's making it crash.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Mon Aug 20, 2018 11:32 am

[24:49:01.27] Logfile "C:/Users/Administratör/AppData/Local/MX Simulator Demo/lastlog.txt" opened
[24:49:01.27] JUGL 0.31
[24:49:01.29] Registry mode is 1366x768x32@60hz
[24:49:01.29] Found mode 1366x768x8@60hz
[24:49:01.29] Found mode 1366x768x16@60hz
[24:49:01.31] Options:
[24:49:01.31] threaded: [off]
[24:49:01.31] Creating window
[24:49:01.47] DirectInput roll call...
[24:49:01.50] vJoy Device (vJoy Device)
[24:49:01.50] 6 axes, 7 keys
[24:49:01.50] axis 0 is absolute
[24:49:01.50] axis 1 is absolute
[24:49:01.50] axis 2 is absolute
[24:49:01.50] axis 3 is absolute
[24:49:01.50] axis 4 is absolute
[24:49:01.50] axis 5 is absolute
[24:49:01.50] Adding axis "vJoyDevice axis 0"
[24:49:01.50] Adding axis "vJoyDevice axis 1"
[24:49:01.50] Adding axis "vJoyDevice axis 2"
[24:49:01.50] Adding axis "vJoyDevice axis 3"
[24:49:01.50] Adding axis "vJoyDevice axis 4"
[24:49:01.50] Adding axis "vJoyDevice axis 5"
[24:49:01.51] vJoy Device (vJoy Device)
[24:49:01.52] 8 axes, 32 keys
[24:49:01.52] axis 0 is absolute
[24:49:01.52] axis 1 is absolute
[24:49:01.52] axis 2 is absolute
[24:49:01.52] axis 3 is absolute
[24:49:01.52] axis 4 is absolute
[24:49:01.52] axis 5 is absolute
[24:49:01.52] axis 6 is absolute
[24:49:01.52] axis 7 is absolute
[24:49:01.52] Adding axis "vJoyDevice#2 axis 0"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 1"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 2"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 3"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 4"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 5"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 6"
[24:49:01.52] Adding axis "vJoyDevice#2 axis 7"
[24:49:01.53] vJoy Device (vJoy Device)
[24:49:01.54] 8 axes, 32 keys
[24:49:01.54] axis 0 is absolute
[24:49:01.54] axis 1 is absolute
[24:49:01.54] axis 2 is absolute
[24:49:01.54] axis 3 is absolute
[24:49:01.54] axis 4 is absolute
[24:49:01.54] axis 5 is absolute
[24:49:01.54] axis 6 is absolute
[24:49:01.54] axis 7 is absolute
[24:49:01.54] Adding axis "vJoyDevice#3 axis 0"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 1"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 2"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 3"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 4"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 5"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 6"
[24:49:01.54] Adding axis "vJoyDevice#3 axis 7"
[24:49:01.55] vJoy Device (vJoy Device)
[24:49:01.55] 8 axes, 32 keys
[24:49:01.55] axis 0 is absolute
[24:49:01.55] axis 1 is absolute
[24:49:01.55] axis 2 is absolute
[24:49:01.55] axis 3 is absolute
[24:49:01.55] axis 4 is absolute
[24:49:01.55] axis 5 is absolute
[24:49:01.55] axis 6 is absolute
[24:49:01.55] axis 7 is absolute
[24:49:01.55] Adding axis "vJoyDevice#4 axis 0"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 1"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 2"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 3"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 4"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 5"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 6"
[24:49:01.55] Adding axis "vJoyDevice#4 axis 7"
[24:49:01.56] 8 axlar, 9 knappar, spelenhet (8 axlar, 9 knappar, spelenhet)
[24:49:01.56] 8 axes, 9 keys
[24:49:01.56] Axis count (8) doesn't match actual number of axes (4)
[24:49:01.56] axis 0 is absolute
[24:49:01.56] axis 1 is absolute
[24:49:01.56] axis 2 is absolute
[24:49:01.56] axis 3 is absolute
[24:49:01.56] Adding axis "8axlar,9knappar,spelenhet axis 0"
[24:49:01.56] Adding axis "8axlar,9knappar,spelenhet axis 1"
[24:49:01.56] Adding axis "8axlar,9knappar,spelenhet axis 2"
[24:49:01.56] Adding axis "8axlar,9knappar,spelenhet axis 3"
[24:49:01.56] End of DirectInput roll call
[24:49:01.56] Choosing pixel format
[24:49:01.57] Setting pixel format 6
[24:49:01.57] Creating OpenGL context

jlv
Site Admin
Posts: 12912
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Can't launch the game.

Postby jlv » Tue Aug 21, 2018 1:23 am

Since it's crashing creating the graphics context it's almost certainly a graphics driver problem. It might be worth trying a different driver version if possible. Sometimes the latest drivers have bugs that aren't in the older driver.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Tue Aug 21, 2018 2:27 pm

I think i have the right graphics driver now since it loaded the opengl graphics, but now it stops at adding an axis.


[0:06:24.81] Logfile "C:/Users/Administratör/AppData/Local/MX Simulator Demo/lastlog.txt" opened
[0:06:24.81] JUGL 0.31
[0:06:24.86] Registry mode is 1366x768x32@60hz
[0:06:24.87] Found mode 320x200x8@70hz
[0:06:24.87] Found mode 320x200x16@70hz
[0:06:24.87] Found mode 320x200x32@70hz
[0:06:24.87] Found mode 512x384x8@70hz
[0:06:24.87] Found mode 512x384x16@70hz
[0:06:24.87] Found mode 512x384x32@70hz
[0:06:24.87] Found mode 640x400x8@70hz
[0:06:24.87] Found mode 640x400x16@70hz
[0:06:24.87] Found mode 640x400x32@70hz
[0:06:24.87] Found mode 640x480x8@59hz
[0:06:24.87] Found mode 640x480x16@59hz
[0:06:24.87] Found mode 640x480x32@59hz
[0:06:24.87] Found mode 656x496x8@59hz
[0:06:24.87] Found mode 656x496x16@59hz
[0:06:24.87] Found mode 656x496x32@59hz
[0:06:24.87] Found mode 800x600x8@60hz
[0:06:24.87] Found mode 800x600x16@60hz
[0:06:24.87] Found mode 800x600x32@60hz
[0:06:24.88] Found mode 1024x768x8@60hz
[0:06:24.88] Found mode 1024x768x16@60hz
[0:06:24.90] Found mode 1024x768x32@60hz
[0:06:24.91] Found mode 1152x864x8@75hz
[0:06:24.91] Found mode 1152x864x16@75hz
[0:06:24.91] Found mode 1152x864x32@75hz
[0:06:24.91] Found mode 1280x720x32@60hz
[0:06:24.91] Found mode 1280x960x8@60hz
[0:06:24.91] Found mode 1280x960x16@60hz
[0:06:24.91] Found mode 1280x960x32@60hz
[0:06:24.91] Found mode 1280x1024x32@60hz
[0:06:24.91] Found mode 1280x1024x8@60hz
[0:06:24.91] Found mode 1280x1024x16@60hz
[0:06:24.91] Found mode 1360x768x8@60hz
[0:06:24.91] Found mode 1360x768x16@60hz
[0:06:24.91] Found mode 1360x768x32@60hz
[0:06:24.91] Found mode 1366x768x8@60hz
[0:06:24.92] Found mode 1366x768x16@60hz
[0:06:24.92] Found mode 1600x1200x8@60hz
[0:06:24.92] Found mode 1600x1200x16@60hz
[0:06:24.92] Found mode 1600x1200x32@60hz
[0:06:24.92] Found mode 1792x1344x8@60hz
[0:06:24.92] Found mode 1792x1344x16@60hz
[0:06:24.92] Found mode 1792x1344x32@60hz
[0:06:24.92] Found mode 1856x1392x8@60hz
[0:06:24.92] Found mode 1856x1392x16@60hz
[0:06:24.92] Found mode 1856x1392x32@60hz
[0:06:24.92] Found mode 1920x1080x32@59hz
[0:06:24.92] Found mode 1920x1440x8@60hz
[0:06:24.92] Found mode 1920x1440x16@60hz
[0:06:24.92] Found mode 1920x1440x32@60hz
[0:06:24.94] Options:
[0:06:24.94] threaded: [off]
[0:06:24.96] Creating window
[0:06:25.32] DirectInput roll call...
[0:06:25.34] vJoy Device (vJoy Device)
[0:06:25.35] 6 axes, 7 keys
[0:06:25.35] axis 0 is absolute
[0:06:25.35] axis 1 is absolute
[0:06:25.35] axis 2 is absolute
[0:06:25.35] axis 3 is absolute
[0:06:25.35] axis 4 is absolute
[0:06:25.35] axis 5 is absolute
[0:06:25.35] Adding axis "vJoyDevice axis 0"
[0:06:25.35] Adding axis "vJoyDevice axis 1"
[0:06:25.35] Adding axis "vJoyDevice axis 2"
[0:06:25.35] Adding axis "vJoyDevice axis 3"
[0:06:25.35] Adding axis "vJoyDevice axis 4"
[0:06:25.35] Adding axis "vJoyDevice axis 5"
[0:06:25.35] vJoy Device (vJoy Device)
[0:06:25.36] 8 axes, 32 keys
[0:06:25.36] axis 0 is absolute
[0:06:25.36] axis 1 is absolute
[0:06:25.36] axis 2 is absolute
[0:06:25.36] axis 3 is absolute
[0:06:25.36] axis 4 is absolute
[0:06:25.36] axis 5 is absolute
[0:06:25.36] axis 6 is absolute
[0:06:25.36] axis 7 is absolute
[0:06:25.36] Adding axis "vJoyDevice#2 axis 0"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 1"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 2"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 3"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 4"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 5"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 6"
[0:06:25.36] Adding axis "vJoyDevice#2 axis 7"
[0:06:25.37] vJoy Device (vJoy Device)
[0:06:25.37] 8 axes, 32 keys
[0:06:25.37] axis 0 is absolute
[0:06:25.37] axis 1 is absolute
[0:06:25.37] axis 2 is absolute
[0:06:25.37] axis 3 is absolute
[0:06:25.37] axis 4 is absolute
[0:06:25.37] axis 5 is absolute
[0:06:25.37] axis 6 is absolute
[0:06:25.37] axis 7 is absolute
[0:06:25.37] Adding axis "vJoyDevice#3 axis 0"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 1"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 2"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 3"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 4"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 5"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 6"
[0:06:25.37] Adding axis "vJoyDevice#3 axis 7"
[0:06:25.38] vJoy Device (vJoy Device)
[0:06:25.39] 8 axes, 32 keys
[0:06:25.39] axis 0 is absolute
[0:06:25.39] axis 1 is absolute
[0:06:25.39] axis 2 is absolute
[0:06:25.39] axis 3 is absolute
[0:06:25.39] axis 4 is absolute
[0:06:25.39] axis 5 is absolute
[0:06:25.39] axis 6 is absolute
[0:06:25.39] axis 7 is absolute
[0:06:25.39] Adding axis "vJoyDevice#4 axis 0"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 1"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 2"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 3"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 4"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 5"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 6"
[0:06:25.39] Adding axis "vJoyDevice#4 axis 7"

jlv
Site Admin
Posts: 12912
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Can't launch the game.

Postby jlv » Wed Aug 22, 2018 2:08 am

If it's crashing during directinput enumeration try unplugging the joystick. If that doesn't work you can make the game ignore directinput entirely by setting this environment variable: JUGL_OPTIONS=[dinput:off]
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Wed Aug 22, 2018 1:37 pm

Thank you so much, now it works.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Wed Aug 22, 2018 2:26 pm

Is there any way to use a controller with directinput off?

jlv
Site Admin
Posts: 12912
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Can't launch the game.

Postby jlv » Thu Aug 23, 2018 1:40 am

It's probably vjoy that's crashing it. If you can use the controller without vjoy it might work.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Thu Aug 23, 2018 6:03 am

I disabled Vjoy and it crashes at

[37:41:54.58] Options:
[37:41:54.58] threaded: [off]
[37:41:54.58] Creating window
[37:41:54.68] Foregrounded and locked
[37:41:54.68] Creating DirectInput object
[37:41:54.70] DirectInput roll call...

jlv
Site Admin
Posts: 12912
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Can't launch the game.

Postby jlv » Fri Aug 24, 2018 1:57 am

Your dinput.dll file might be corrupted. Try reinstalling directx.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Fri Aug 24, 2018 12:36 pm

Ok i found the problem. Somehow whenever i connect to my controller through bluetooth (i don't know if it works wired) the game crashes upon startup. When i remove the controller from my devices the game runs perfectly fine. Any solution to this?y

deepestman
Posts: 11
Joined: Sat Aug 18, 2018 1:27 pm
Team: Privateer

Re: Can't launch the game.

Postby deepestman » Fri Aug 24, 2018 12:48 pm

I just tried connecting it with wire aswell, it doesn't work. I can't launch the game with my controller connected in any way. That kinda sucks.


Return to “Help / Troubleshooting”

Who is online

Users browsing this forum: broland278 and 14 guests