server port forwarding

Post your questions here
User avatar
echayward
Posts: 29
Joined: Wed Jan 11, 2017 9:14 pm
Location: Western Cape, South Africa
Contact:

server port forwarding

Postby echayward » Tue Sep 15, 2020 3:10 pm

hi there, so i dont know why it just cant work but im having some trouble in port forwarding. if i check on https://www.yougetsignal.com/tools/open-ports/ it says my ports are closed. i have forwarded port 19800 to my ipv4 address 192.168.8.100, i have made an exeption for mxserver in windows firewall, i have added new rule in windows defender firewall advanced security and added port 19800 and also made sure that theres an exeption for mxserver in there, iv also created a static ip and tried that but nothing seems to work, open port check tool says port is closed and anyone outside my network still cant join my mx sim server.

any help would be much apopreciated
Image

User avatar
Wahlamt
Posts: 7630
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden
Contact:

Re: server port forwarding

Postby Wahlamt » Tue Sep 15, 2020 8:00 pm

Is the UDP forwarded and not TCP port?
To troubleshoot, can you connect via localhost?:
127.0.0.1:19800

Does via LAN work?
192.168.1.100:19800

If this works, is your friends trying to connect to your public ip address?

User avatar
echayward
Posts: 29
Joined: Wed Jan 11, 2017 9:14 pm
Location: Western Cape, South Africa
Contact:

Re: server port forwarding

Postby echayward » Tue Sep 15, 2020 9:02 pm

Wahlamt wrote:Is the UDP forwarded and not TCP port?
To troubleshoot, can you connect via localhost?:
127.0.0.1:19800

Does via LAN work?
192.168.1.100:19800

If this works, is your friends trying to connect to your public ip address?

19800 is port forwarded on udp
yes lan works. my server works fine localy, just when my freind tries to join "using my public ip" it doesnt work.
if i type the command "netstat -a" into command prompt "cmd" it shows there that udp 192.168.8.50 19800 port is being used. i have even disabled my firewall on my pc and on my router, still nothing
Image

User avatar
echayward
Posts: 29
Joined: Wed Jan 11, 2017 9:14 pm
Location: Western Cape, South Africa
Contact:

Re: server port forwarding

Postby echayward » Wed Sep 16, 2020 6:57 pm

after hours of trying finally got it right. it was because i was on an lte router and had to configuire some other settings for it to work. was doing everything right otherwise.
anyone having trouble with lte routers in fuuture regarding port forwarding can pm me!
thanks
regards
Image


Return to “Help / Troubleshooting”

Who is online

Users browsing this forum: No registered users and 6 guests