How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Post your questions here
Ryanphillips
Posts: 22
Joined: Sat Jun 10, 2017 1:08 am
Team: Privateer

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Ryanphillips » Sun Jun 11, 2017 11:56 pm

why do you think it keeps freezing? is that more on my computers graphics? thanks for trying to help on the other issue. i am still trying to figure it out. i have mxsim on wine but cant find the tracks when i put into wine folder. i don't know. i will keep messing with it. i don't mind that so much but the game freezing really sucks, I'm just trying to practice staying on the bike lol and cant because after 2 laps it freezes. it never lags or anything before that tho

User avatar
Wahlamt
Posts: 5840
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Wahlamt » Mon Jun 12, 2017 6:51 am

Not sure really. How old/new is your Mac, and which one is it? Other than that, does lowering your graphics (and restarting your game) fix the issue? Otherwise install xquartz (if not already installed) may be worth a go. When I have more time in the future, I might look into why tracks aren't recognized.

jlv
Site Admin
Posts: 12314
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby jlv » Tue Jun 13, 2017 1:04 am

It sounds like he's using the native quartz driver and you're using the x11 driver on xquartz. x11+xquartz is older so it might be less buggy.

Accorind to https://wiki.winehq.org/Useful_Registry_Keys you have to set Software\Wine\Drivers\Graphics to "x11" to use xquartz.

| Which graphic driver to use. Currently only useful on Mac.
| mac: Use the native quartz driver (default)
| x11: Use the X11 driver
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

User avatar
Wahlamt
Posts: 5840
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Wahlamt » Tue Jun 13, 2017 4:36 am

jlv wrote:It sounds like he's using the native quartz driver and you're using the x11 driver on xquartz. x11+xquartz is older so it might be less buggy.

Accorind to https://wiki.winehq.org/Useful_Registry_Keys you have to set Software\Wine\Drivers\Graphics to "x11" to use xquartz.

| Which graphic driver to use. Currently only useful on Mac.
| mac: Use the native quartz driver (default)
| x11: Use the X11 driver

Sounds interesting, going to look into what mine says some day.

Any idea on why tracks won't show up in game when it's a normal track that works well on a normal windows installation?

nlettera
Posts: 7
Joined: Mon Jan 18, 2016 5:09 am

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby nlettera » Tue Jun 13, 2017 8:40 pm

I'm on a Mac too, and am wanting to buy the game. Just a question, why would you use wine instead of bootcamp? Wouldn't partitioning a section of your hard drive for windows make more sense than using wine, that way you would actually be installing and playing the game in a true native version of windows?

jlv
Site Admin
Posts: 12314
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby jlv » Wed Jun 14, 2017 1:00 am

Real Windows would probably be a little faster but then you have to reboot to Windows just to have a game.

Wahlamt wrote:Any idea on why tracks won't show up in game when it's a normal track that works well on a normal windows installation?

Which track?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

Ryanphillips
Posts: 22
Joined: Sat Jun 10, 2017 1:08 am
Team: Privateer

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Ryanphillips » Thu Jun 15, 2017 8:25 pm

I finally got all the old wine files removed and able to play!!!! But now my question to anyone that can help. Some of the tracks I upload to my mxsim folder work fine. Some gear does. Helmets. But some bikes I'm not able to find anywhere. And a couple pieces of gear. For the most part it works. But is it something super obvious that I'm screwing up on some and not the others?

User avatar
Wahlamt
Posts: 5840
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Wahlamt » Mon Jul 03, 2017 2:42 pm

Just tried to put some tracks in, they all worked first try, so I will have to download more tracks and see if I can find one that doesn't work (haven't tried to load them, but they show up..). These worked:
Scrub or Dead
2012 Freestone
2012 Steel City
2017 Agueda Superlow
Black Mesa
2013 Bellpuig

User avatar
Wahlamt
Posts: 5840
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Wahlamt » Tue Aug 01, 2017 7:26 pm

I get this every now and then. What mainly caused it for me was switching bikes. If I ride for example "FC450(2017)" and switches to the "FC250(2017)", this happens. Not every time, but often enough. I switched bikes 2 times in a row (from the fc 450 to 250) and that happened. After the 2nd restart it worked. Then I restarted the game and went 250 -> 450 and it crashed again. I was running it as following:

Code: Select all

wine mx.exe --editor

Image

Noteworthy might be that I get these errors when I launch it from the terminal (if I don't just the editor, I just double click mx.exe so have no clue if there are any error messages then):

Code: Select all

wine mx.exe --editor
fixme:winediag:start_process Wine Staging 2.0 is a testing version containing experimental patches.
fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
fixme:ntdll:NtCreateNamedPipeFile Message mode not supported, falling back to byte mode.
fixme:ntdll:NtCreateNamedPipeFile Message mode not supported, falling back to byte mode.
fixme:ntdll:NtCreateNamedPipeFile Message mode not supported, falling back to byte mode.
fixme:shcore:SetProcessDpiAwareness (2): stub
fixme:ntdll:NtCreateNamedPipeFile Message mode not supported, falling back to byte mode.


After it crashes, this comes up in the terminal.

Code: Select all

mx.exe(1168,0x401fe000) malloc: *** mach_vm_map(size=67108864) failed (error code=3)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug
wine: Assertion failed at address 0x000b:0xa17e3496 (thread 0009), starting debugger...
fixme:ntdll:NtCreateNamedPipeFile Message mode not supported, falling back to byte mode.


Once I force quit, I get this in the terminal:

Code: Select all

Killed: 9


Adding the lastlog.txt as well:

Code: Select all

[8:16:22.52] Logfile "C:/users/kristoffer/Local Settings/Application Data/MX Simulator/lastlog.txt" opened
[8:16:22.52] JUGL 0.31
[8:16:22.53] MX Simulator version 2017-07-26-1356 snapshot
[8:16:22.99] SetProcessDpiAwareness failed
[8:16:23.52] Registry mode is 1440x900x32@60hz
[8:16:23.52] Found mode 2560x1600x32@60hz
[8:16:23.52] Found mode 2560x1600x8@60hz
[8:16:23.52] Found mode 2560x1600x16@60hz
[8:16:23.52] Found mode 2048x1280x32@60hz
[8:16:23.52] Found mode 2048x1280x8@60hz
[8:16:23.52] Found mode 2048x1280x16@60hz
[8:16:23.52] Found mode 1024x768x32@60hz
[8:16:23.52] Found mode 1024x768x8@60hz
[8:16:23.52] Found mode 1024x768x16@60hz
[8:16:23.52] Found mode 1440x900x8@60hz
[8:16:23.52] Found mode 1440x900x16@60hz
[8:16:23.52] Found mode 1680x1050x32@60hz
[8:16:23.52] Found mode 1680x1050x8@60hz
[8:16:23.52] Found mode 1680x1050x16@60hz
[8:16:23.52] Found mode 1280x800x32@60hz
[8:16:23.53] Found mode 1280x800x8@60hz
[8:16:23.53] Found mode 1280x800x16@60hz
[8:16:23.53] Found mode 1024x640x32@60hz
[8:16:23.53] Found mode 1024x640x8@60hz
[8:16:23.53] Found mode 1024x640x16@60hz
[8:16:23.53] Found mode 720x450x32@60hz
[8:16:23.53] Found mode 720x450x8@60hz
[8:16:23.53] Found mode 720x450x16@60hz
[8:16:23.53] Found mode 1920x1200x32@60hz
[8:16:23.53] Found mode 1920x1200x8@60hz
[8:16:23.53] Found mode 1920x1200x16@60hz
[8:16:23.53] Found mode 840x525x32@60hz
[8:16:23.53] Found mode 840x525x8@60hz
[8:16:23.53] Found mode 840x525x16@60hz
[8:16:23.53] Found mode 2880x1800x32@60hz
[8:16:23.53] Found mode 2880x1800x8@60hz
[8:16:23.53] Found mode 2880x1800x16@60hz
[8:16:23.53] Found mode 800x600x32@60hz
[8:16:23.53] Found mode 800x600x8@60hz
[8:16:23.53] Found mode 800x600x16@60hz
[8:16:23.53] Found mode 640x480x32@60hz
[8:16:23.53] Found mode 640x480x8@60hz
[8:16:23.53] Found mode 640x480x16@60hz
[8:16:23.58] Options:
[8:16:23.58]  threaded: [off]
[8:16:23.58] Creating window
[8:16:23.66] Foregrounded and locked
[8:16:23.66] DirectInput roll call...
[8:16:23.66] Joystick 0 (Xbox 360 Wired Controller)
[8:16:23.67] 6 axes, 15 keys
[8:16:23.67] axis 0 is absolute
[8:16:23.67] axis 1 is absolute
[8:16:23.67] axis 2 is absolute
[8:16:23.67] axis 3 is absolute
[8:16:23.67] axis 4 is absolute
[8:16:23.67] axis 5 is absolute
[8:16:23.67] Adding axis "Joystick0 axis 0"
[8:16:23.67] Adding axis "Joystick0 axis 1"
[8:16:23.67] Adding axis "Joystick0 axis 2"
[8:16:23.67] Adding axis "Joystick0 axis 3"
[8:16:23.67] Adding axis "Joystick0 axis 4"
[8:16:23.67] Adding axis "Joystick0 axis 5"
[8:16:23.67] End of DirectInput roll call
[8:16:23.67] Choosing pixel format
[8:16:23.70] Setting pixel format 153
[8:16:23.70] Creating OpenGL context
[8:16:23.89] 8 texture units
[8:16:23.89] GL_VENDOR: Intel Inc.
[8:16:23.89] GL_RENDERER: Intel Iris Pro OpenGL Engine
[8:16:23.89] GL_VERSION: 2.1 INTEL-10.25.17
[8:16:23.89] GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod  WGL_EXT_extensions_string WGL_EXT_swap_control
[8:16:24.98] WM_SIZE message 0x0
[8:17:14.65] Foregrounded and locked
[8:17:14.65] WM_SIZE message 1440x900
[8:17:18.16] Resetting
[8:17:18.17] Remembering lines
[8:17:18.21] Cleaning up
[8:17:18.21] Deallocating bikes
[8:17:18.21] Finished deallocating bikes
[8:17:18.24] Scanning
[8:17:18.31] Loading lighting
[8:17:18.36] Loading terrain
[8:17:19.09] WM_SIZE message 0x0
[8:17:19.50] Terrain texture rendering with framebuffer objects
[8:17:19.50] Loading shading
[8:17:19.53] Loading shadows
[8:17:19.53] Loading tileinfo
[8:17:19.54] Loading tilemap
[8:17:20.22] Loading flaggers
[8:17:20.50] Loading billboards
[8:17:20.50] Loading statues
[8:17:20.66] Loading map
[8:17:20.69] Analyzing lines
[8:17:20.70] Loading bikes
[8:17:22.24] Warning: Can't load @fc450v2016_side_plates.jm
[8:17:22.35] Warning: Can't load @fc450v2016_front_plate.jm
[8:17:24.88] Warning: Can't load @fc450v2016_side_plates.jm
[8:17:24.88] Warning: Can't load @fc450v2016_front_plate.jm
[8:17:29.10] Foregrounded and locked
[8:17:29.10] WM_SIZE message 1440x900
[8:17:29.10] 437 MB texture memory used
[8:17:29.10] Max loading delay was 10.742000 (Loading terrain)
[8:17:29.10] Setting working set range to 1073741824 - 2113929215
[8:17:29.10] Working set successfully updated
[8:18:02.05] Resetting
[8:18:02.06] Remembering lines
[8:18:02.10] Cleaning up
[8:18:02.10] Deallocating bikes
[8:18:02.10] Finished deallocating bikes
[8:18:02.13] Analyzing lines
[8:18:02.16] Loading bikes
[8:18:02.41] Warning: Can't load @fc250v2016_side_plates.jm
[8:18:02.52] Warning: Can't load @fc250v2016_front_plate.jm
[8:18:04.92] Warning: Can't load @fc250v2016_side_plates.jm
[8:18:04.92] Warning: Can't load @fc250v2016_front_plate.jm

jlv
Site Admin
Posts: 12314
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby jlv » Wed Aug 02, 2017 1:37 am

It's a memory allocation bug in something. Probably wine but it could be MXS. I did a pretty careful check for malloc bugs before 1.11 but it's possible I missed something. If you set the environment variable MX_CHECK_ALLOC=1 the game will check for errors in its own allocator. So you can try that but I'm guessing it won't find anything because the bug is in wine.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

poesty
Posts: 49
Joined: Fri Sep 12, 2014 7:58 pm
Team: Privateer

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby poesty » Sat Aug 26, 2017 8:00 am

how you open a link like one of emf ? it says

Safari can not open 'mxsimulator: EMFRacing2.mxsim.fr: 19802' because macOs do not recognize Internet addresses starting with 'mxsimulator' ...

i using wine to play mxsim
2015 champ mclb nieuwlingen mx1
2016 champ mclb juniors mx1

User avatar
Wahlamt
Posts: 5840
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Wahlamt » Sat Aug 26, 2017 10:18 am

poesty wrote:how you open a link like one of emf ? it says

Safari can not open 'mxsimulator: EMFRacing2.mxsim.fr: 19802' because macOs do not recognize Internet addresses starting with 'mxsimulator' ...

i using wine to play mxsim

You cannot to this as it's through wine. You may be able to do this if you want to code a bit yourself. But shot answer for the standard user: Wine masks the mx.exe application and macos can't see it/don't know how to open it. So you will simply have to write the URL in the multiplayer menu.

Smithj76_
Posts: 6
Joined: Thu Sep 28, 2017 5:23 pm
Team: Privateer
Location: Houston, TX

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Smithj76_ » Wed Nov 15, 2017 4:01 pm

So i recently updated my mac to high sierra, and ever since i have when i go to open mx.exe with wine the screen will either go all black or all white and all i can do is reset my computer for my computer to work again, anyone know how to fix this? Thanks in advance
Go Big Or Go Home

User avatar
Wahlamt
Posts: 5840
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Wahlamt » Thu Nov 16, 2017 8:54 am

Smithj76_ wrote:So i recently updated my mac to high sierra, and ever since i have when i go to open mx.exe with wine the screen will either go all black or all white and all i can do is reset my computer for my computer to work again, anyone know how to fix this? Thanks in advance

I'll look at this weekend if I have time. Thanks for letting me know.

Smithj76_
Posts: 6
Joined: Thu Sep 28, 2017 5:23 pm
Team: Privateer
Location: Houston, TX

Re: How to install Mx Simulator on Mac + Tracks, skins, using editor etc.

Postby Smithj76_ » Thu Nov 16, 2017 5:50 pm

Wahlamt wrote:
Smithj76_ wrote:So i recently updated my mac to high sierra, and ever since i have when i go to open mx.exe with wine the screen will either go all black or all white and all i can do is reset my computer for my computer to work again, anyone know how to fix this? Thanks in advance

I'll look at this weekend if I have time. Thanks for letting me know.

thanks man!
Go Big Or Go Home


Return to “Help / Troubleshooting”

Who is online

Users browsing this forum: Google [Bot] and 4 guests