Low FPS all of a sudden

Post your questions here
mason#317
Posts: 71
Joined: Mon Jul 23, 2012 3:41 pm
Location: South Africa

Low FPS all of a sudden

Postby mason#317 » Mon Aug 07, 2017 7:06 am

hi guys , Mx sim was running perfectly fine until today.. i was getting 125 fps on all my tracks and everything was running smooth. When i started it up today im only getting 15/20fps in the menu and on the tracks which is unplayable.

As you can see i have VSync turned off and i have a GTX 1050.

Image

Image

maggett
Posts: 354
Joined: Sun Mar 06, 2016 2:05 pm
Team: Architech
Contact:

Re: Low FPS all of a sudden

Postby maggett » Mon Aug 07, 2017 1:29 pm

try turning off threaded optimization in the control panel i remember that messing with alot of peoples fps

and have you tried restarting you pc since you said its only happening today? might just be some weird bug
2018 EMF EU 250SX East Coast Champion
Image

mason#317
Posts: 71
Joined: Mon Jul 23, 2012 3:41 pm
Location: South Africa

Re: Low FPS all of a sudden

Postby mason#317 » Mon Aug 07, 2017 1:42 pm

maggett wrote:try turning off threaded optimization in the control panel i remember that messing with alot of peoples fps

and have you tried restarting you pc since you said its only happening today? might just be some weird bug


I did try turning it off and that didn't help unfortunately, I have restarted it several times.. I figured out that If i change the Video mode to Windowed it works perfect but when i change it to full screen it only runs at 15fps

maggett
Posts: 354
Joined: Sun Mar 06, 2016 2:05 pm
Team: Architech
Contact:

Re: Low FPS all of a sudden

Postby maggett » Mon Aug 07, 2017 11:51 pm

mason#317 wrote:
maggett wrote:try turning off threaded optimization in the control panel i remember that messing with alot of peoples fps

and have you tried restarting you pc since you said its only happening today? might just be some weird bug


I did try turning it off and that didn't help unfortunately, I have restarted it several times.. I figured out that If i change the Video mode to Windowed it works perfect but when i change it to full screen it only runs at 15fps


have you tried both default full screen and setting the resolution yourself?
2018 EMF EU 250SX East Coast Champion
Image

mason#317
Posts: 71
Joined: Mon Jul 23, 2012 3:41 pm
Location: South Africa

Re: Low FPS all of a sudden

Postby mason#317 » Tue Aug 08, 2017 4:52 am

maggett wrote:
mason#317 wrote:
maggett wrote:try turning off threaded optimization in the control panel i remember that messing with alot of peoples fps

and have you tried restarting you pc since you said its only happening today? might just be some weird bug


I did try turning it off and that didn't help unfortunately, I have restarted it several times.. I figured out that If i change the Video mode to Windowed it works perfect but when i change it to full screen it only runs at 15fps


have you tried both default full screen and setting the resolution yourself?


Yes i have, and unfortunately only windowed resolution seems like its working.. I thought it might be the graphics card playing up but it works perfectly on all my other games.. It doesn't seem to make a difference weather my laptop is plugged in or not on full screen , When its in windowed it makes a big difference

sputnicwarriors
Posts: 6
Joined: Thu Aug 11, 2011 5:16 pm
Team: pro circuit

Re: Low FPS all of a sudden

Postby sputnicwarriors » Wed Aug 16, 2017 11:13 am

same here man! playing pubg and other games on high/ultra but all of the sudden mxs is lagging like crazy! only windowed work...

mason#317
Posts: 71
Joined: Mon Jul 23, 2012 3:41 pm
Location: South Africa

Re: Low FPS all of a sudden

Postby mason#317 » Mon Aug 21, 2017 5:03 am

sputnicwarriors wrote:same here man! playing pubg and other games on high/ultra but all of the sudden mxs is lagging like crazy! only windowed work...


glad its not only me.. :mrgreen: If you do find a fix please let me know

mason#317
Posts: 71
Joined: Mon Jul 23, 2012 3:41 pm
Location: South Africa

Re: Low FPS all of a sudden

Postby mason#317 » Tue Aug 22, 2017 11:58 am

If anybody is having the same problems as me i managed to find a solution.. All i did was turn off Game overlay/Share feature in the GeForce Experience app, Now i can play with 125fps in fullscreen mode without any problems.


Return to “Help / Troubleshooting”

Who is online

Users browsing this forum: deepestman and 1 guest