MXS Linux Install

Post your questions here
Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

MXS Linux Install

Postby Shanasman450 » Fri May 11, 2018 1:22 am

I'm having one hell of a time installing on linux. Anyone have any knowledge of how to do this?

User avatar
Wahlamt
Posts: 6567
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden
Contact:

Re: MXS Linux Install

Postby Wahlamt » Fri May 11, 2018 5:58 am



What distro are you running?

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Fri May 11, 2018 11:52 am

My bad, I forgot to mention. Ubuntu 16.04

User avatar
Wahlamt
Posts: 6567
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden
Contact:

Re: MXS Linux Install

Postby Wahlamt » Fri May 11, 2018 6:42 pm

Shanasman450 wrote:My bad, I forgot to mention. Ubuntu 16.04

Video above should get you up and running.

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Sun May 13, 2018 5:22 am

It's up and running now with the exception of sound. I can play just fine, but I get no sound (yes, my sound is turned up, all the way matter of fact, and mute is off. Do you happen to know a fix for this issue off hand? I'll do a bit of digging on the forums. Not that that seems to do any good. I've searched every one of my issues thus far with no results, start my own thread and then get handed several links to threads pertaining to what I had tried searching for. It's like when you can't get something to work and the second you try to show someone it works. It's kind of comical in a way :lol: . Anyway, thanks for the help man. It's much appreciated.

User avatar
Wahlamt
Posts: 6567
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden
Contact:

Re: MXS Linux Install

Postby Wahlamt » Sun May 13, 2018 7:41 am

Look at this post, maybe try to install the libasound library? (Or some more) http://forum.mxsimulator.com/viewtopic.php?f=17&t=8955&p=724351&hilit=Libraries#p724351

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Sun May 13, 2018 8:41 am

After watching your video I went to that page and installed all the listed libraries. Unless it just didn't install right and I didn't notice, it's installed.

User avatar
Wahlamt
Posts: 6567
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden
Contact:

Re: MXS Linux Install

Postby Wahlamt » Sun May 13, 2018 12:42 pm

Tried apt update/upgrade/restart your computer?

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Sun May 13, 2018 1:20 pm

Yep.

jlv
Site Admin
Posts: 12824
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: MXS Linux Install

Postby jlv » Mon May 14, 2018 1:03 am

There might be a clue in ~/.mxsimulator/lastlog.txt.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Mon May 14, 2018 3:53 am

Code: Select all

[423951:27:21.50] 12 buttons
[423951:27:21.50] 6 axes (Relative)
[423951:27:21.50]
XDevice: "HP Wireless hotkeys"
[423951:27:21.50] 255 keys
[423951:27:21.50]
XDevice: "HP WMI hotkeys"
[423951:27:21.50] 255 keys
[423951:27:21.54] Listing directories
[423951:27:21.54] Listing archives
[423951:27:21.55] Creating file list
[423951:27:21.55] File index complete
[423951:27:21.57] Opening audio
[423951:27:21.57] cannot open audio device default (No such file or directory)
[423951:27:21.57] Can't open /dev/dsp
[423951:27:21.57] 8 texture units
[423951:27:21.57] GL_VENDOR: Intel Open Source Technology Center
[423951:27:21.57] GL_RENDERER: Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) x86/MMX/SSE2
[423951:27:21.57] GL_VERSION: 3.0 Mesa 17.2.8
[423951:27:21.57] GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array G:

Code: Select all

[423951:27:34.35] Loading billboards
[423951:27:34.36] Loading statues
[423951:27:34.37] 2 degenerate triangles deleted in @sx2013/stuppercurved.jm
[423951:27:34.64] @sx2013/graynoisefade.png reduced to 16x16 (originally 64x64)
[423951:27:34.93] Loading map
[423951:27:34.95] Analyzing lines
[423951:27:34.97] Loading bikes
[423951:27:35.10] 280 MB texture memory used
[423951:27:35.10] Max loading delay was 0.161002 (Loading flaggers)
[423951:27:50.89] Deallocating bikes
[423951:27:50.89] Finished deallocating bikes
[423951:27:50.89] Deallocating track
[423951:27:50.90] Finished deallocating track
[423951:27:50.90] Freeing memory (1)
[423951:27:50.90] Closing input devices
[423951:27:50.92] Closing audio
[423951:27:50.94] Writing config files
[423951:27:50.95] Freeing memory (2)
[423951:27:50.97] Freeing memory (3)
[423951:27:50.99] Freeing file list
[423951:27:51.00] Freeing memory (4)
[423951:27:51.02] Deleting textures
[423951:27:51.04] Deleting models
:


These are the only two instances I see where audio is mentioned.

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Mon May 14, 2018 4:01 am

Here's the entire file if that would help any.

Shanasman450
Posts: 18
Joined: Sun Apr 15, 2018 4:07 am
Team: Privateer (AKA newb)

Re: MXS Linux Install

Postby Shanasman450 » Mon May 14, 2018 4:04 am

Never mind then. The file I chose to send as an attachment didn't send with the post.

User avatar
Wahlamt
Posts: 6567
Joined: Mon Sep 13, 2010 3:15 pm
Team: MLG Compton
Location: Sweden
Contact:

Re: MXS Linux Install

Postby Wahlamt » Mon May 14, 2018 6:07 am

Shanasman450 wrote:Never mind then. The file I chose to send as an attachment didn't send with the post.

Attachments doesn't work anymore, just copy the whole file into the code tag like you did above.

jlv
Site Admin
Posts: 12824
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: MXS Linux Install

Postby jlv » Mon May 14, 2018 9:06 pm

Looks like it failed trying to open the default ALSA device. If you're running PulseAudio make sure you have the pulseaudio alsa plugin installed. It has to be the i686 version since the mx binary is 32 bit.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.


Return to “Help / Troubleshooting”

Who is online

Users browsing this forum: deepestman and 1 guest