Page 1 of 1

Please help, how do I fix this? "Error reading lighting"

Posted: Sun Feb 10, 2019 10:12 pm
by MotoDanny
I'm far into creating my track, and the game had me re enter my registration code, and reset all my settings, and now my track won't load! Any suggestions?

This is what the game says "Error reading lighting: Unknown identifier 'dynamic'
Bad height field parameters
Error reading heights"

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Sun Feb 10, 2019 10:55 pm
by Cody Dawe
can you post whats inside your lighting file please? put it in code blocks.

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 3:51 am
by jlv
Your probably have "dynamic lighting 1" instead of " "dynamic_lighting 1". Spaces and underscores are not interchangeable.

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 4:33 am
by MotoDanny
Ok I fixed that! But it still says: "Bad height field parameters" and "Error reading heights"

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 4:34 am
by MotoDanny
jlv wrote:Your probably have "dynamic lighting 1" instead of " "dynamic_lighting 1". Spaces and underscores are not interchangeable.


Ok I fixed that! But it still says: "Bad height field parameters" and "Error reading heights"

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 4:37 am
by MotoDanny
sneakyKittyGaming wrote:can you post whats inside your lighting file please? put it in code blocks.

Lighting file: sun_vector [ -0.6830 0.2588 0.6830]
sun_color [ 0.607 0.572 .498 ]
ambient [ 0.607 0.572 .498 ]
sky_n @FloatyMX/skybox/sky-n.png
sky_e @FloatyMX/skybox/sky-e.png
sky_s @FloatyMX/skybox/sky-s.png
sky_w @FloatyMX/skybox/sky-w.png
sky_u @FloatyMX/skybox/sky-u.png
sky_env @FloatyMX/skybox/sky-env.png
flare_element [ 0.0 1.0 ] [ 0.5 0.5 0.5 ] 0.75 @glare.png
flare_element [ 0.0 -0.0 ] [ 0.0 0.0 0.125 ] 0.5 @glare.png
flare_element [ 0.0 -0.25 ] [ 0.0 0.125 0.0 ] 0.5 @glare.png
flare_element [ 0.0 -0.5 ] [ 0.125 0.0 0.0 ] 0.5 @glare.png
flare_element [ 0.0 -0.9 ] [ 0.0 0.0 0.0625 ] 0.4 @ring.png
flare_element [ 0.0 -0.95 ] [ 0.0 0.0625 0.0 ] 0.5 @ring.png
flare_element [ 0.0 -1.0 ] [ 0.0625 0.0 0.0 ] 0.6 @ring.png
flare_vector [ 0 0.5373 0.8434]
fog [ 0 .48 .58 ] .0001
dynamic_lighting 0

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 7:05 am
by Cody Dawe
MotoDanny wrote:
sneakyKittyGaming wrote:can you post whats inside your lighting file please? put it in code blocks.

Lighting file: sun_vector [ -0.6830 0.2588 0.6830]
sun_color [ 0.607 0.572 .498 ]
ambient [ 0.607 0.572 .498 ]
sky_n @FloatyMX/skybox/sky-n.png
sky_e @FloatyMX/skybox/sky-e.png
sky_s @FloatyMX/skybox/sky-s.png
sky_w @FloatyMX/skybox/sky-w.png
sky_u @FloatyMX/skybox/sky-u.png
sky_env @FloatyMX/skybox/sky-env.png
flare_element [ 0.0 1.0 ] [ 0.5 0.5 0.5 ] 0.75 @glare.png
flare_element [ 0.0 -0.0 ] [ 0.0 0.0 0.125 ] 0.5 @glare.png
flare_element [ 0.0 -0.25 ] [ 0.0 0.125 0.0 ] 0.5 @glare.png
flare_element [ 0.0 -0.5 ] [ 0.125 0.0 0.0 ] 0.5 @glare.png
flare_element [ 0.0 -0.9 ] [ 0.0 0.0 0.0625 ] 0.4 @ring.png
flare_element [ 0.0 -0.95 ] [ 0.0 0.0625 0.0 ] 0.5 @ring.png
flare_element [ 0.0 -1.0 ] [ 0.0625 0.0 0.0 ] 0.6 @ring.png
flare_vector [ 0 0.5373 0.8434]
fog [ 0 .48 .58 ] .0001
dynamic_lighting 0

well since your previous issue is solved, then this is no longer needed lol. for the other issue, try replacing each file one at a time with one from another track(for terrain.png make sure the size of the image is defined correctly in your shading/shadingx2 files) until you find which file was corrupted. keep backups.

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 8:05 am
by Wahlamt
MotoDanny wrote:
jlv wrote:Your probably have "dynamic lighting 1" instead of " "dynamic_lighting 1". Spaces and underscores are not interchangeable.


Ok I fixed that! But it still says: "Bad height field parameters" and "Error reading heights"

It has to do with your terrain.png or terrain.hf file I think. Is the terrain.png 1025x1025 or 2049x2049? And what's in your terrain.hf file?

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 9:48 am
by MotoDanny
Wahlamt wrote:
MotoDanny wrote:
jlv wrote:Your probably have "dynamic lighting 1" instead of " "dynamic_lighting 1". Spaces and underscores are not interchangeable.


Ok I fixed that! But it still says: "Bad height field parameters" and "Error reading heights"

It has to do with your terrain.png or terrain.hf file I think. Is the terrain.png 1025x1025 or 2049x2049? And what's in your terrain.hf file?

My terrain.hf just says "nul" repeatedly, and the terrain png is 2049x2049

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Mon Feb 11, 2019 6:06 pm
by Wahlamt
MotoDanny wrote:
Wahlamt wrote:
MotoDanny wrote:
Ok I fixed that! But it still says: "Bad height field parameters" and "Error reading heights"

It has to do with your terrain.png or terrain.hf file I think. Is the terrain.png 1025x1025 or 2049x2049? And what's in your terrain.hf file?

My terrain.hf just says "nul" repeatedly, and the terrain png is 2049x2049

This in your terrain.hf file, that's the problem:

Code: Select all

10 1 0 0

This is assuming you have a blank track so far.

Re: Please help, how do I fix this? "Error reading lighting"

Posted: Tue Feb 12, 2019 5:47 am
by MotoDanny
Thanks for the help everybody! I got it fixed!