Possible bug: Constant crashing when deleting decals

Post your questions here
Post Reply
Jrife548
Posts: 626
Joined: Sat Nov 19, 2016 9:15 pm
Team: looking 4 gamer team

Possible bug: Constant crashing when deleting decals

Post by Jrife548 »

Building a new track, and my game is crashing about 1/10 times I delete a decal. Only started on most recent snapshot, never happened before.
Image
jlv
Site Admin
Posts: 14930
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Possible bug: Constant crashing when deleting decals

Post by jlv »

Are there treadmarks on the track when it happens?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
Jrife548
Posts: 626
Joined: Sat Nov 19, 2016 9:15 pm
Team: looking 4 gamer team

Re: Possible bug: Constant crashing when deleting decals

Post by Jrife548 »

No. It happens with or without treadmarks.
Image
jlv
Site Admin
Posts: 14930
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Possible bug: Constant crashing when deleting decals

Post by jlv »

OK. There were definitely a lot of changes to the decal insert/delete code so I'll have a look.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
jlv
Site Admin
Posts: 14930
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Possible bug: Constant crashing when deleting decals

Post by jlv »

Jrife548 wrote: Tue Jan 23, 2024 12:17 am Building a new track, and my game is crashing about 1/10 times I delete a decal. Only started on most recent snapshot, never happened before.
I've been trying to reproduce this and not having any luck. Is there anything special I have to do?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
sethypeety
Posts: 331
Joined: Mon Jul 18, 2016 2:51 pm
Team: SpitFire Aprilia
Location: in your face
Contact:

Re: Possible bug: Constant crashing when deleting decals

Post by sethypeety »

jlv wrote: Mon Apr 01, 2024 12:35 am
Jrife548 wrote: Tue Jan 23, 2024 12:17 am Building a new track, and my game is crashing about 1/10 times I delete a decal. Only started on most recent snapshot, never happened before.
I've been trying to reproduce this and not having any luck. Is there anything special I have to do?
I've started having this problem on a track I just started working on. It started happening after I deleted the treadmark lines from the tileinfo file, after adding the lines back to the one they were originally deleted from it continued crashing (after deleting about 10-20 decals). I grabbed another tileinfo file (no treadmarks) and put it in the track and it stopped crashing. (Also running Snapshot 2024-03-30)
Image
jlv
Site Admin
Posts: 14930
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: Possible bug: Constant crashing when deleting decals

Post by jlv »

sethypeety wrote: Mon Apr 08, 2024 4:47 pm I've started having this problem on a track I just started working on. It started happening after I deleted the treadmark lines from the tileinfo file, after adding the lines back to the one they were originally deleted from it continued crashing (after deleting about 10-20 decals). I grabbed another tileinfo file (no treadmarks) and put it in the track and it stopped crashing. (Also running Snapshot 2024-03-30)
Do you still have one of the tileinfo files that it crashed with?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
Post Reply