2021-11-22 snapshot (Updated 2021-11-25)

Post anything about MX Simulator here. Please. I'm begging you.
jlv
Site Admin
Posts: 14274
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

2021-11-22 snapshot (Updated 2021-11-25)

Post by jlv »

Changes:
  • Added /saveframetimes command. This saves the frame times in "frametimes.txt".
  • Fixed Javascript function mx.add_env_sound returning 0 instead of -1 on error.
  • Removed shader program and terrain render method options - shaders and framebuffer objects are now required.
  • Rewrote rendering code to only use common subset of OpenGL 3.1 and OpenGL ES 3.0.
  • Now requires at least OpenGL 3.1 or OpenGL ES 3.0.
  • Enabled trilinear texture filtering.
  • Added --glversion command line option.
If you want to use --glversion, it's "--glversion <major version>.<minor version><dialect>", where <dialect> is one of "es", "core" or "compatibility". So for a 4.5 core context it'd be "--glversion 4.5core" or 3.1 es would be "--glversion 3.1es". Probably best to just leave it at the default 3.1core though.

Updated 2021-11-24:
  • Fixed unlit objects with 0 specular intensity rendering as transparent.
  • Removed statue wireframes in editor.
Updated 2021-11-25:
  • Statue wireframes can now be turned on/off in editor.
  • Wireframes now use GL_LINES instead of GL_LINE_LOOP.
  • Wireframes now use least detailed LOD instead of most detailed.
  • Added message in loading screen when it's loading the track script.
Updated 2021-11-26:
  • Small change in tilemap rendering to remove unnecessary draw calls.
Windows users: https://mxsimulator.com/snapshots/mx-2021-11-26-1614.exe
Linux users: https://mxsimulator.com/snapshots/mxbin-2021-11-26-1614

Replace mx.exe or mxbin with one of the above files. The default location for mx.exe should be "C:\Program Files (x86)\MX Simulator". I'd keep a backup of the originals since these aren't well tested.
Last edited by jlv on Sun Nov 28, 2021 12:30 am, edited 2 times in total.
Reason: Updated for 2021-11-26
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
Jakob Hubbard
Posts: 931
Joined: Fri Nov 24, 2017 3:16 am
Team: Phil's
Location: Cold

Re: 2021-11-22 snapshot

Post by Jakob Hubbard »

Currently getting 8fps in the editor on one of my tracks. It was solid before but now it's unusable.
Image
lucasking42
Posts: 8
Joined: Wed Mar 31, 2021 4:58 am
Team: Privateer

Re: 2021-11-22 snapshot

Post by lucasking42 »

In the loading screen, I get to "Loading bikes... done" and my it freezes.
lucasking42
Posts: 8
Joined: Wed Mar 31, 2021 4:58 am
Team: Privateer

Re: 2021-11-22 snapshot

Post by lucasking42 »

lucasking42 wrote: Tue Nov 23, 2021 3:24 am In the loading screen, I get to "Loading bikes... done" and my game freezes. Sorie, mie eNgluSh nOr gUd
JimmyGriffin
Posts: 8
Joined: Sun Oct 20, 2019 6:44 pm
Team: Privateer

Re: 2021-11-22 snapshot

Post by JimmyGriffin »

lucasking42 wrote: Tue Nov 23, 2021 3:26 am
lucasking42 wrote: Tue Nov 23, 2021 3:24 am In the loading screen, I get to "Loading bikes... done" and my game freezes. Sorie, mie eNgluSh nOr gUd
It work for me noob.
Image
Jakob Hubbard
Posts: 931
Joined: Fri Nov 24, 2017 3:16 am
Team: Phil's
Location: Cold

Re: 2021-11-22 snapshot

Post by Jakob Hubbard »

I’ve seen issues with rendering large objects such as stadiums as well with this new snapshot that I thought I’d add in here
Image
motokid499
Posts: 1549
Joined: Sun Nov 04, 2012 2:25 am
Team: Premium MotoSpodes
Location: Canada
Contact:

Re: 2021-11-22 snapshot

Post by motokid499 »

Something really wrong going on for me, random hitches and slow motion type freezing. FPS displays 124/125 consistently but game is unplayable.
Tanner Rogers
cnigrin285
Posts: 137
Joined: Thu May 25, 2017 3:20 pm
Team: Privateer
Location: United States
Contact:

Re: 2021-11-22 snapshot

Post by cnigrin285 »

I'm getting stutters in game also my in game editor is almost unusable.
Wilson156
Posts: 993
Joined: Fri Feb 17, 2012 12:28 am
Team: AektivCo
Contact:

Re: 2021-11-22 snapshot

Post by Wilson156 »

I was getting frame drops from 125 sitting still then id move forward and it'd drop to 40. Also parts of my stadiums and signs weren't showing up.
Robert Wilson | AektivCo
Image
ddmx
Posts: 5331
Joined: Sun Apr 20, 2008 3:36 pm
Location: Midland MI

Re: 2021-11-22 snapshot

Post by ddmx »

Quick Iron Man 2021. Pretty much constant 125fps, no drops below 100.

Ryzen 7 2700x
GTX 1660
The MXS 1%
ddmx
Posts: 5331
Joined: Sun Apr 20, 2008 3:36 pm
Location: Midland MI

Re: 2021-11-22 snapshot

Post by ddmx »

Didn't think it would be, but editor is nearly unresponsive. 0-5fps
The MXS 1%
jlv
Site Admin
Posts: 14274
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: 2021-11-22 snapshot

Post by jlv »

Jakob Hubbard wrote: Tue Nov 23, 2021 1:50 am Currently getting 8fps in the editor on one of my tracks. It was solid before but now it's unusable.
I think that's from the wireframes. Would anyone miss them if I removed them?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
jlv
Site Admin
Posts: 14274
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: 2021-11-22 snapshot

Post by jlv »

lucasking42 wrote: Tue Nov 23, 2021 3:24 am In the loading screen, I get to "Loading bikes... done" and my it freezes.
After "loading bikes" but before it reports the texture memory? Might have something to do with the track javascript. Does it happen on every track? Can you post the lastlog.txt file?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
jlv
Site Admin
Posts: 14274
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: 2021-11-22 snapshot

Post by jlv »

Jakob Hubbard wrote: Tue Nov 23, 2021 5:05 am I’ve seen issues with rendering large objects such as stadiums as well with this new snapshot that I thought I’d add in here
It'd be really helpful to have something specific. What am I looking for and what track makes it happen?
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
jlv
Site Admin
Posts: 14274
Joined: Fri Nov 02, 2007 5:39 am
Team: No Frills Racing
Contact:

Re: 2021-11-22 snapshot

Post by jlv »

motokid499 wrote: Tue Nov 23, 2021 6:25 am Something really wrong going on for me, random hitches and slow motion type freezing. FPS displays 124/125 consistently but game is unplayable.
You could get more hitches if you were running 1024x1024 terrain textures in copy mode before since copy mode limits that to 256x256. Now that copy mode is gone if you ask for 1024x1024 you get it along with all the hitches that come with that setting. Run it at 256x256 and it should be the same as before, maybe even a little faster since it avoids the back buffer to texture copy.
Josh Vanderhoof
Sole Proprietor
jlv@mxsimulator.com
If you email, put "MX Simulator" in the subject to make sure it gets through my spam filter.
Post Reply